THE BEGINNERS GUIDE TO BLENDER

Jonathan Lampel
blenderhd.com

This page if for mandatory legal shenanigans.

The content in this eBook is for informational purposes only. Any advice that I give within this eBook is my opinion based on my own personal experience.

Please understand that there are some links contained in this guide, but I do not benefit from them financially.

The material in this guide may include some information about products or services by third parties. Third Party Materials include products and opinions expressed by their owners. I do not assume responsibility or liability for any Third Party material or opinions.

My publication of third party materials does not constitute my guarantee of any information, instruction, opinion, products or services contained within said material. Publication of such third party material is simply a recommendation and an expression of my own opinion of that material.

No part of this publication shall be transmitted, reproduced, or sold in whole or in part in any form, without the prior written consent of the author. All trademarks and registered trademarks appearing in this guide are the property of their respective owners.

Users of this guide are advised to do their own due diligence when it comes to making decisions and all information, products, services that have been provided should be independently verified by your own qualified professionals. By reading this guide, you agree that myself and my company is not responsible for the success or failure of your business decisions relating to any information presented in this guide.
# Contents

Preface ................................................................................................................................. 4  
About this Book ...................................................................................................................... 4  
Intro to 3D Software ............................................................................................................ 4  
What is 3D? ............................................................................................................................ 4  
So what is Blender? ............................................................................................................... 6  
Interface ............................................................................................................................... 7  
Navigation ............................................................................................................................. 7  
Selection ............................................................................................................................... 8  
Transforming Objects ......................................................................................................... 9  
3D Cursor ............................................................................................................................ 10  
Editors ................................................................................................................................ 11  
Layouts ................................................................................................................................ 13  
Modeling .............................................................................................................................. 14  
Edit Mode ............................................................................................................................. 15  
Modifers ............................................................................................................................... 21  
Sculpting ................................................................................................................................ 26  
Shading and Texturing ....................................................................................................... 29  
Texturing .............................................................................................................................. 29  
UV’s ...................................................................................................................................... 29  
Texture Painting ................................................................................................................ 34  
Shading ................................................................................................................................. 38  
Animation ............................................................................................................................. 45  
Keyframes ............................................................................................................................. 45  
Physics .................................................................................................................................. 49  
Particles ............................................................................................................................... 49  
Rigid Bodies ........................................................................................................................ 49  
Cloth ..................................................................................................................................... 49
Fire and smoke.......................................................... 50
Fluids ....................................................................... 50
Rendering and Compositing ......................................... 51
Rendering ................................................................. 51
Cameras ..................................................................... 51
Render Settings .......................................................... 52
Compositing ............................................................... 54
Additional Resources ................................................. 55
Tutorials ..................................................................... 55
News and Forums ....................................................... 55
Assets ....................................................................... 55
Inspiration ................................................................. 55
Preface

About this Book

Hey, nice to meet you! I’m Jonathan, and I run the website blenderhd.com. As a thank-you for signing up to my new site, I’ve created this free eBook for those who want to get started making awesome models and visual effects right away. It’s 57 pages long, and covers the basics of what you’ll need to know. Since I can’t go over every single thing Blender can do in 57 pages, I put a list of links to resources at the end of each section where you can find additional information and tutorials around the web.

Intro to 3D Software

Blender is only one of many 3D graphics applications. Before we can take a look at Blender and its alternatives, however, let’s talk about 3D computer graphics in general.

What is 3D?

3D software is used to create a virtual representation of anything. Even things that don’t exist. Essentially, you take something from your imagination and make the idea more real than has ever been possible in the history of the world. Sound awesome? It totally is! Imaginary environments, sexy concept cars, absurdly realistic portraits, goofy character designs, epic posters, and emotional animations are just a few examples of what’s possible to make with 3D software. Not easy, mind you, but definitely possible.

I am confident you have seen or experienced a plethora of 3D graphics. What you may not know, however, is just how widely they are used. It is always best to have a goal in mind when starting to learn a new skill, so I have outlined below a few industries in which 3D content is heavily utilized today. See any that interests you?

- Video Games
  - Most modern games, from iPhone to Xbox, rely completely on 3D characters interacting with 3D environments.
- Film and Television
  - Some form of CGI or VFX appears in almost every shot of today’s movies. More recently, directors have been animating their entire film before it is even shot with live actors.
- Marketing
Because 3D images and animations can look lifelike and flawless at the same time, those looking for advertising are rapidly turning to 3D artists to create advertisements. This not only includes television commercials, but print advertising as well.

- **Architecture**
  - Architects often employ 3D artists to create representations of what they want their building to look like when completed. This can help in pitching a project to investors (for a skyscraper, bridge, library, etc...) or in selling a home before it is built.

- **Medicine**
  - Anatomically correct 3D models help medical practitioners create surgical plans and simulate organs. Scanned data, such as MRI voxel data, allows doctors to take 3 dimensional snapshots of a patient's brain or organs.

- **Science**
  - One large 3D industry is scientific visualization, which helps scientists simulate and study everything from black holes to microbes.

- **Education**
  - Besides just creating engaging images for textbooks, interactive 3D models can help students better understand topics relating to anatomy and physiology, geology, engineering, archeology, architecture, or chemistry.

- **Everything Else**
  - With the rise of consumer 3D printing, the possibilities really are endless. You can create your own board game pieces, replace a broken dishwasher part, build a gun from scratch (not recommended!), or even create custom 18k gold jewelry. Heck, scientists are even on their way to 3D printing human organs.

Clearly, there really is no better time to learn a 3D program. Especially since you can start right now! But which software is for you? In this book we will be learning Blender (hence the title), but I want to list some other helpful software here as well in case you might want to use them alongside Blender. Each package has its own strengths and weaknesses, so you might find that one suits you better than another. Software is just a tool to get you to your destination, so choose whichever one will help you achieve your goals the easiest.

- **Autodesk 3DS Max** and **Maya** ($3,675 each)
  - Industry proven tools for modeling, animation, simulation, and rendering. Although both packages can do either, 3DS Max is used primarily in the game industry and Maya is used mainly for film and animation. You can download both programs for free for student use only.

- **Zbrush** ($795)
  - All about digital sculpting. It is designed to be used with a tablet, and is very artist friendly. Another sculpting alternative is **3D Coat** ($379).

- **Unity** (Free basic, Pro $75/Month)
A game engine that works well alongside Blender. Unity shines when it comes to mobile, 2D, or simple 3D games. When it comes to making next-gen games for consoles or PC however, I would recommend Unreal (5% commission).

- **Sketchup** (Free basic, Pro $590)
  - When it comes to building from blueprints, Google’s Sketchup is your friend. Great for building houses and mechanical parts.

- **Autodesk Inventor** ($7,295)
  - If your interest in 3D is to invent machines or build working robot prototypes, Inventor is where you should be looking. Free for students.

- **Open Inventor** ($?)
  - The go-to software for those in the fields of medicine and biology. There is no apparent price or way to purchase, so it is likely not open to the public at this time.

- **Nuke** ($2,500 - $5,600)
  - Nuke is a fantastic compositing tool, and is widely used in film production. Similar to After Effects, but more powerful and extremely flexible.

- **Photoshop** ($19.99/Month)
  - A very helpful companion for Blender. Photoshop can be used to paint textures, create matte backgrounds, and color correct rendered images.

**So what is Blender?**

Blender is an all-in-one 3D software that can be used to model, sculpt, texture, animate, camera track, render, and composite awesome looking graphics from start to finish. The best part? It’s free for everyone!

Free often means low quality, but thankfully that’s not the case with Blender. It was written in 1995 by Ton Roosendaal as an in-house software for a Dutch animation studio called NeoGeo. It was originally sold to other studios as well, but in early 2002 Blender needed to be shelved due to economic decline. To keep his project alive, Roosendaal convinced investors to convert Blender to a GNU General Public License by raising €100,000 in only seven weeks. Blender has been free ever since, and is continually being developed thanks to generous donations from the community.

I started using Blender in 2011 because, like most people, I like free things. I stuck with it over time thanks to its awesome community. I have consumed so much free learning material, benefited from helpful in-depth critiques on forums, and been motivated by the many contests. Thanks to Blender and its community I’ve been able to make some crazy artwork and meet new friends along the way.

So what are you waiting for? **Go get it!**
Interface

When you first open Blender, all the buttons, menus, and panels might seem a little intimidating. Any 3D program will seem crazy complex at first, and that’s because they are! Blender has to be, considering that you can use it to make almost anything you can imagine. That freedom, however, takes some getting used to. But it doesn’t mean that it has to be hard to learn! By the end of this chapter, you should be comfortable enough navigating the software to create your first project.

If you would rather learn Blender’s interface in video format, I recommend watching the free Introduction for Beginners course on BlenderCookie.com.

Navigation

First, let’s forget the menus and focus only on the 3D viewport. It’s is the big area in the middle as shown below:

The viewport is where you will do most of your work in Blender, so it’s best to get familiar with it now. Listed below are the three main navigation controls:

- Zoom: Scroll wheel up or down
- Orbit: Hold down the middle mouse button (scroll wheel) and drag
- Pan: Hold down SHIFT, then click and drag middle mouse button
If you are using an Apple, Wacom, or other two button mouse, don’t worry! It’s much easier if you use a three button mouse, but you can still get around with only two by changing your preferences. Go to the header menu and click File → User Preferences. A window will pop up, and navigate to the Input category. On the left under “Mouse”, check the box for Emulate 3 Button Mouse. To save this as default, click Save User Settings at the bottom, and exit the window.

Now if you go back to the 3D view, you can use these controls to navigate:

- Zoom: CTRL+ALT+LMB
- Orbit: ALT+LMB
- Pan: SHIFT+ALT+LMB

*Note: From here on, LMB = Left Mouse Button, MMB = Middle Mouse Button, and RMB = Right Mouse Button*

You can also use the number pad to rotate around the view:

- Top: 7
- Front: 1
- Right: 3

To view from the opposite direction, press CTRL in conjunction. Example: bottom view is CTRL+7
To view from the local direction, add the key SHIFT. Example: local top view is SHIFT+7
You can even combine these together! Example: local bottom view is CTRL+SHIFT+7

**Selection**

Now that you can move around like a pro, let’s start selecting and transforming objects. You may have noticed already that Blender is a little different than other applications when it comes to selecting
objects, in that you right click to select. This may take a few minutes to get used to, but it will be helpful in the long run because it allows users to multitask when doing complex tasks.

The object you select will be highlighted in bright orange. Practice selecting by switching between the camera, lamp, and cube.

There are three more ways to select objects in Blender. You can toggle select multiple objects in Blender by \textit{SHIFT+right clicking} on objects. To use the marquee select, press \textit{CTRL+LMB}. To box select, use the hotkey \textit{b+LMB}.

Notice how the last object you select will be highlighted with orange, and the other selected objects are highlighted in red. The orange object called the \textit{active object}. More on this later, but you can think of the active object as the king over all your other selected objects.

To select all objects, press the hotkey “a”. To deselect all objects, press “a” again.

If you ever find that it’s hard to select overlapping objects, press \textit{ALT+RMB} to bring up a selection menu for everything under your mouse.

### Transforming Objects

The three main ways to transform objects in any 3D program is by translating, rotating, and scaling. Translate simply means “move” or “grab” in this context.

One way to transform an object is by using the \textit{manipulator handles}. The manipulator (also called widget, gizmo, or grabber-thingy by some) is by default three arrows that point in three different directions. The red arrow points towards the X axis, the green arrow towards the Y axis, and the blue arrow toward the Z axis. There is a little compass in the bottom left corner of the 3D view in case you ever need a reminder. Click and drag on one of colored the arrows to move the object along that axis. Dragging from the white circle inside the arrows will move the object in relation to your view.

At the bottom of the 3D view, you will see five buttons that control the manipulator. From left to right: toggle on/off, translate, rotate, scale, and orientation.

The first button that looks like the three axes will toggle the manipulator on and off. This can be helpful if you find it distracting later on. The second arrow-shaped button turns on the translate handles, and is selected by default. Selecting curve-shaped button will switch the handles to rotation handles, and
selecting the stick-with-a-square-on-it-shaped button will switch to the scale handles. You can also
SHIFT+click these buttons to use multiple handles at the same time.

You can also manipulate an object using only hotkeys. Press “g” to grab, “r” to rotate, and “s” to scale.
You can constrain the transformation to an axis by pressing “x”, “y”, or “z” during the transformation. To
constrain to two axes, press SHIFT+ whichever axis you would like to leave out. Left click to confirm.

For example, if I want to move my cube along the ground without it moving up or down, I would press
g+SHIFT+z to move it in any direction except the Z.

You can also transform along the local axis as by pressing the axis key twice. Example: to move an
object in its local X direction, I would press G+x+x and then left click to confirm.

Try using all transformation types to position the default cube on its edge, similar to this:

Once you have done so, try scaling the cube along the Y axis. You will notice that the shape is
becoming distorted. This is where that Transform Orientation menu we saw on the last page comes in
handy. Right now it is set to “Global”. You can think of global orientation like north, south, east and
west. No matter which direction you are facing, a compass will always point north. Let’s click on the
menu and switch the orientation to “Local”. Now we can scale the cube much more naturally. The local
axes are relative to the object, similar to left and right. You can also set the orientation to the objects
Normal, Gimbal axis, or the View, but those are not used very frequently. Most of the time, just I set it
back to “Global” to avoid confusion.

3D Cursor

Left clicking inside of Blender’s 3D view will move around the 3D Cursor, which looks like this:
The 3D Cursor is used to position objects in 3D space, and can be very useful. New objects are created at the center of the 3D Cursor.

To move the cursor back to the center, go to the menu Object→Snap→Cursor to Center

In that same Object→Snap menu, you can see other helpful actions as well. You can also snap the selected object to the grid or cursor, or snap the cursor to the selected object, center, grid, or active object. The hotkey for this menu is SHIFT+s

Editors

Blender has a LOT of buttons. Fortunately, they are organized fairly well. You don’t need to memorize everything, but it would be best to have a general understanding of what’s where so you can find your way around.

In the below screenshot, you will see how Blender’s default layout is divided into five editors: The Info Panel (red), 3D View (blue), Timeline (green), Outliner (pink), and Properties (orange).

The Info panel contains general menus that are useful throughout the application: File, Render, Window, and Help. To the right the Help menu is a Layout manager, which we will discuss more in a bit. To the right of that is the Scene manager, where you can create multiple scenes within one file. Next is a dropdown that says Blender Render. This menu switches rendering engines. Finally, on the very right, we have our scene info that tells us what version we are using, how many vertices, faces, triangles, objects, and lamps we have, as well as how much memory Blender is currently using. Additionally, you can drag down the header to expose recently used Python operators.
If there is an error, you will see it here highlighted in red

The 3D view, like we already discussed, is where we will do the majority of our work. Most editors are divided into four sections. The work area, header, toolbar, and properties panel. In the screenshot below, the toolbar is highlighted blue, the properties panel pink, and the header red:

The header is usually found at the bottom of a window. It contains menus and options relating specifically to its editor, which in this case is the 3D View.

The top portion of the toolbar contains commonly used tools grouped together in tabs. You can quickly switch between tabs by hovering over them and scrolling with the mouse wheel. If you find that you use one sub-panel often, you can pin it by right clicking on the name. The bottom third of the toolbar is where you are able to edit the properties your last action. You can close the toolbar by either collapsing it all the way to the left or by pressing “t”. To open it, just press “t” again or click the little “+” icon on the top left side of the screen.
The Properties panel (not to be confused with the Properties editor!) can be accessed by either the “+” icon near the top right of the screen or the hotkey “n”. Here you will find options relating to the viewport and selected object.

The Timeline is found below the 3D view. With it, you can play back animations, set key frames, and do all that other time related stuff. Don’t worry, we’ll talk about animation a bit more later.

The Outliner is essentially a hierarchal view of the scene. You can search for and select objects, view parenting relations, and toggle visibility (eye icon), selectability (pointer icon), and renderability (camera icon).

The Properties Editor is where we, well, edit properties. It is divided into twelve different settings tabs:

- Render, Render Layers, Scene, World, Object, Constraints
- Modifiers, Object Data, Materials, Textures, Particles, Physics

The Render, Render Layers, Scene, and World tabs apply the whole scene, while all other tabs to the right of those are relative to the selected object. We will be exploring these tabs a bit more in the later chapters.

## Layouts

On the very left of every header you will see a grey box containing the editor’s symbol and two arrows indicating a popup menu. For example, the 3D view’s symbol is a cube. Clicking on this will allow you to switch editor types.

Remember the Layout Manager we saw earlier in the Info header? Right now it contains nine default layouts for common tasks. You can switch between them either from the dropdown menu, or by using the hotkeys CTRL+Right Arrow and CTRL+Left Arrow. To maximize any editor within your layout, use the hotkey CTRL+Up Arrow. For a more in-depth look at layouts, [watch my free tutorial on how to customize and save your own layouts for maximum efficiency](#).
Modeling

Now that we can move around Blender, let’s start making stuff! There are three ways to create objects and place them into the scene:

1. The “Create” tab in the 3D View toolbar
2. “Add” menu in 3D View header
3. Hotkey SHIFT+A

As we found out in the previous chapter, our objects will be placed on the 3D Cursor. There are all sorts of objects we can make in Blender, but we should focus on the mesh objects to start with.

For this example I am going to delete the default cube by pressing either “x” or “Delete”, and adding the mesh type “Monkey”.

If we go up one tab in the toolbar to the “Tools” tab, we can see a few new actions:

- Mirror: Inverts the selected object along an axis
- Duplicate: Creates an exact copy of the object
- Duplicate Linked: Creates an exact copy that shares data with the original. Any changes you make in Edit Mode will effect both objects. (We’ll talk about Edit Mode shortly!)
- Smooth or Flat Shading: Interprets the surface of the model as either smooth or angular.
These simple actions may be very useful, but they don’t allow us to change the underlying structure of the model in any way. So far we have been working in *Object Mode*, but to edit our objects we need to go into *Edit Mode*. To switch modes, use the Mode dropdown (or in this case *drop up*, if that’s a word!) menu located in the 3D View’s header.

Mesh objects have six main Modes: Object, Edit, Sculpt, Vertex Paint, Weight Paint, and Texture Paint. For now, choose Edit Mode. You can also quickly switch between Object Mode and Edit Mode by pressing *TAB*.

*Note: Only the Active Object will enter Edit Mode, so be sure you have the right object selected.*

**Edit Mode**

When you enter edit mode, you will see that our model is made up of lots of little components. The three mesh components are *vertices*, *edges*, and *faces*.

Vertices (singular is vertex) are simply points in space. They have no volume or shape, and are infinitely small. *They only have a location.*

An edge is a bridge between two vertices. *It has a length, but no width.*

A face is three or more connected edges that form a geometric shape. The common terms for faces that you will hear in the 3D industry are *Tris* (triangles), *Quads* (quadrilateral, or any four sided polygon), and *N-Gon* (Polygon with more than four sides, N represents a variable).
You can select each component by right clicking, just like you would select in object mode. By default, the selection type is set to vertex select. You can switch between the vertex, edge, and face selection types using this toggle menu found in the 3D view header:

You can also hold Shift while selecting to select multiple components at the same time.

Because an edge is just two connected vertices, you can also select any edge in vertex select mode by simply selecting the edge’s two vertices. Likewise, you can select a face by selecting the vertices or edges that surround it. This is very different from Maya, where each component has its own specific mode.

Now that we can select and move components, we’re ready to start modeling! But how do people go from a simple cube to something awesome?
First, we need a way to add new geometry in edit mode. We could never make anything from a cube if we only had six faces to work with. The two most essential tools in modelling in any program are the *extrude* and *insert edge loop* tools.

*Extrude* allows us to pull out or push in vertices, edges, and faces from our mesh in the direction they are facing. You can find this tool in the toolbar under Tool->Add->Extrude Region, or by simply pressing the hotkey “e”. Move your mouse around until the extrusion reaches your desired length. Click to confirm.

In the example below, I extruded a face from the side of a sphere:

If you multiple faces, they will extrude as one unit if you use Extrude Region or as separate units if you use Extrude Individual.
If you would like to change the properties of your extrusion after you click to confirm the action and before you start a new action, you can do so in the operator panel at the bottom of the toolbar, or by pressing the hotkey "F6".
Before we get into the insert edge loop tool, it’s essential to know what an edge loop is. An edge _loop_ is a set of connected edges that usually wraps around the surface of the mesh. An edge _ring_ is a set of edges that run perpendicular to an edge loop.

Here I have an edge loop selected (ALT+RMB):

![Edge loop selected](image)

Edge ring selected (select menu -> edge ring):

![Edge ring selected](image)
You can add a new edge loop with the hotkey CTRL+R, or the Add -> Loop Cut and Slide button in the toolbar. The first click places the edge loop in the direction that you want, and the second click confirms where you want the loop in relation to the two adjacent loops. Then one more click to confirm.

One last useful tool is the subdivide tool. This can be found in the toolbar above the loop cut tool, or with the hotkey W -> Subdivide. The subdivide tool divides our faces into four parts, which gives us more geometry to work with. In the example below, the plane on the left is not subdivided. The plane in the center is subdivided once, and the one on the right is subdivided twice.

Congratulations! Now that you know how to move objects and components, as well as add geometry with the extrude, add edge loop, and subdivide tools, you’re ready to start modeling! Try to use a cube to make this simple boxy giraffe:
Unfortunately I don’t have enough space here to cover modelling exhaustively. But, if you’re itching to get started, I would highly recommend checking out the tutorials listed at: blender.org/support/tutorials and cgcookie.com

Modifiers

In Blender, we can use *modifiers* to change our mesh non-destructively. When you make changes in edit mode, those changes are considered *destructive* because there is no way to go back and change your edits later, unless you undo all your hard work. Modifiers are *non-destructive* because we can edit them at any time, without losing any information.

Usually, you’ll want to work with modifiers while in object mode. To add a modifier to an object, go to the modifiers tab in the properties window (looks like a wrench), and click Add Modifier. You’ll see a huge list of all available modifiers, but don’t be intimidated. We’ll just take a look at the essential ones for now.
The one you will likely use most often is the *Subdivision Surface* modifier. This will add geometry by subdividing it (just like our subdivide tool), and then it smooths out (averages) the faces. The amount of subdivisions is how many times Blender will subdivide the faces. Be careful with high values though, because each division multiplies the previous face count by four! Too many faces, and the computer will start to slow down.

If we add a subdivision surface to our giraffe, it turns into a Gumby giraffe.
As you can see, this modifier helps smooth out shapes and add geometry. In the example below, Cube 1 is the default cube, Cube 2 has a Subsurf modifier of level 3 applied, and Cube 3 is the same as 2 but with two extra edge loops along the right and top edges to sharpen the corners.

If you want to edit these new vertices in Edit Mode, hit the modifier’s Apply button, which will make the changes permanent. Modifiers can only be applied in Object Mode.

Another extremely useful modifier is the Mirror modifier. This modifier creates a copy of the mesh that is flipped across the object’s origin (the orange dot). If you can’t see any effect when you use the modifier, go into edit mode and move your mesh around.

You can specify which axes you would like to be mirrored with the X Y and Z checkboxes. The Merge option automatically combines vertices along the seam that are close together, and the Clipping option will cause the mesh to stick along the center seam (if the vertices are merged together) so that there is no gap.

You may have noticed the row of icons at the top of the modifiers, next to the modifier’s name. The camera toggles whether or not the modifier will appear when rendering (more on this in a later
chapter), the eye toggles its visibility, the cube toggles its visibility in Edit Mode, and the triangle toggles whether the modifier appears applied in Edit Mode.

One last important modifier is the *Array* modifier. This one can create many instances of the mesh, all along a line or otherwise defined path. There are three different ways to offset the array instances.

- **Constant Offset**: Offsets the instances according to the scene units. For example, you would want to use this one to create 5 fence posts exactly 6 meters apart from each other.
- **Relative Offset**: Offsets based on the object’s size. Think of this as a percentage, where 1 = 100%. In the image below, I have the relative offset set to 1.1 in the X direction and 0.4 in the Y direction. Notice how the each cube is 110% of the cube’s width to the right of each other, and 40% of the cube’s depth in the Y direction.

- **Object Offset**: This uses another object’s location, scale, and rotation to define the offset. If you wanted each instance to be 2 meters to the right, scaled up 10%, and rotated 30 degrees consecutively, you would assign an object to the Object Offset that has the following transformations (can be found in "n" properties toolbar):
In this case I used an *Empty* type object for the Object Offset object, because I don’t need it for anything else except its location, rotation, and scale information. The cool this is, you can edit the first object in edit mode and all the instances will change accordingly!

Modifiers are awesome because they can be stacked on top of each other. Blender starts at the top of the list and works its way down. Try using one cube with one subsurf, one array, and two mirror modifiers to get the following effect:

Want to learn more about modifiers? Blender Diplom has an awesome YouTube playlist that covers every single modifier and how to use it. [Check it out!](https://www.youtube.com/)
Sculpting

There’s one more way to shape objects in Blender, and that is in *Sculpt Mode*. You can find it in the same dropdown list that we use to switch between object and edit mode.

Sculpting is a much more natural and artistic way to manipulate objects. At the top of the toolbar are the brush settings. Clicking on the brush will bring up a menu of all available brushes. Below is a list of what each brush does, according to the Blender Wiki:

- **Blob**: Pushes mesh outward or inward into a spherical shape with settings to control the amount of pinching at the edge of the sphere.
- **Clay** (hotkey C): Similar to the Draw brush, but includes settings to adjust the plane on which the brush acts.
- **Clay Strips**: Similar to the Clay brush, but it uses a cube test to define the brush area of influence rather than a sphere.
- **Crease**: Creates sharp indents or ridges by pushing or pulling the mesh, while pinching the vertices together.
- **Draw (D)**: Moves vertices inward or outward, based the average normal of the vertices contained within the drawn brush stroke.
- **Fill**: The Fill brush works like the Flatten brush, but only brings vertices below the brush plane upwards. The inverse of the Scrape brush is to Deepen by pushing vertices above the plane downward.
- **Flatten (T)**: The Flatten brush finds an ‘area plane’ located by default at the average height above/below the vertices within the brush area. The vertices are then pulled towards this plane. The inverse of the Flatten brush is the Contrast brush which pushes vertices up or down away from the brush plane.
- **Grab (G)**: Grab is used to drag a group of points around. Unlike the other brushes, Grab does not modify different points as the brush is dragged across the model. Instead, Grab selects a group of vertices on mousedown, and pulls them to follow the mouse. The effect is similar to moving a group of vertices in Edit mode with proportional-editing enabled, except that Grab can make use of other Sculpt Mode options (like textures and symmetry).
- **Inflate (I)**: Similar to Draw, except that vertices in Inflate mode are displaced in the direction of their own normals.
- **Layer (L)**: This brush is similar to Draw, except that the height of the displacement layer is capped. This creates the appearance of a solid layer being drawn. This brush does not draw on top of itself; a
brush stroke intersects itself. Releasing the mouse button and starting a new stroke will reset the
depth and paint on top of the previous stroke.
- Nudge: Moves vertices in the direction of the brush stroke.
- Pinch (P): Pinch pulls vertices towards the center of the brush. The inverse setting is Magnify, in
which vertices are pushed away from the center of the brush.
- Rotate: Rotates vertices within the brush in the direction the cursor is moved.
- Scrape: The Scrape brush works like the Flatten brush, but only brings vertices above the plane
downwards. The inverse of the Scrape brush is to Peak by pushing vertices above the plane up away
from the plane.
- Smooth (S, or hold SHIFT): As the name suggests, eliminates irregularities in the area of the mesh
within the brush’s influence by smoothing the positions of the vertices.
- Snake Hook: Pulls vertices along with the movement of the brush to create long, snake-like forms.
- Thumb: Similar to the Nudge brush, this one flattens the mesh in the brush area, while moving it in
the direction of the brush stroke.

Similar to Photoshop or Gimp, the Radius slider adjusts the brush size (hotkey F) while the strength
adjusts how strong the brush is (SHIFT+F). The add and subtract toggle switches between pulling out or
pushing in the vertices (hold CTRL while sculpting). Pretty self-explanatory so far.

By default, sculpting only moves around vertices that already exist. That means that in order to add
detail, we would need to subdivide our model. However, there is a way to sculpt the model without
having to worry about poly-count or topology. Dynamic Topology will dynamically add in new geometry
in the areas we sculpt, so that we can get as much or as little detail that we need. can be enabled in the
toolbar in the Dyntopo panel.
Now I can sculpt weird faces right on the side of a cube! It looks messy now, but sculpts are usually **retopologized** anyway.

A great resource for **sculpting** and **dynamic topology** is CGCookie.com. Check out their awesome tutorials to learn more!
Shading and Texturing

So now we can create cool objects in Blender, but they look very bland in that default grey. The next step toward making awesome renders and animations is to texture and shade our objects so that they look believable and can more clearly express whatever we want them to.

Texturing

In computer graphics, textures are the images that we use to color our models. They can be hand painted in Blender, Photoshop, or other texturing software, photos from a camera, or a combination of the two. In this section, I’ll show you how to paint textures directly onto a model in Blender.

UV’s

Textures are two dimensional, but our models are three dimensional. That means we need a way to wrap the images around our geometry. The most common solution to unwrap our models (almost like a Christmas present!) and flatten them out. We do this in what is called $UV$ space. Similar to how X, Y, and Z are our three dimensions when modeling, U and V are our two dimensions when texturing. These two separate dimensions allow us to define exactly how and where we want our textures applied.

In this example, we will unwrap a monkey head so that we can texture it. Remember how to spit windows from earlier? Just drag the little triangle lines in the bottom left corner of the 3D View to the right, and switch the new window to the UV/Image Editor window.
If you switch the monkey into Edit Mode, you’ll see a tab in the toolbar (hotkey T) called Shading/UVs. In the UVs panel is a dropdown list called Unwrap that will give us different ways to automatically unwrap our model (hotkey U).

For now we’ll just use the first option, which is simply Unwrap. Make sure everything is selected first (hotkey A), so that Blender will unwrap the whole object.
On the left you can see that Blender has taken our model and flattened it out into two dimensions. It has separated the eyes and head into separate UV islands since they are not actually connected on our model. The problem now is that the faces which are largest in UV space will have the most texture detail, but the face, which should have the most detail, is squished in the middle!

Luckily, we can use *seams* to tell Blender how we want to lay out our UV’s. When you hear the word seams, you probably think of shirt or pants seams. It’s a perfect analogy. The tailor lays out the flat 2D cloth in such a way that it will wrap into the perfect 3D shape. We’re just doing that backwards! We separate our 3D shape so that it lays out perfectly in 2D.

To assign seams to a model, select the edges you would like to be separated and click the Mark Seams button in the toolbar. I selected the edges around the monkey’s face, so that it will later lay out flat.
Once seams are marked, the edges appear as a dashed red line in the 3D view so that we can see them clearly. I marked a ring around each ear, the back of the ear, and a line from her forehead to the back of the skull as well, because those sections do not need to be connected in UV space. Since textures can sometimes not blend well between seams, it is good practice to hide them in places that are not easily visible.
Now when we press Unwrap, our monkey head lays out much more neatly. You can see that the edges which were marked as seams have become unseparated.
Now we can start texturing! If you would like to learn more about seams and UV unwrapping, check out this awesome CG Cookie tutorial.

**Texture Painting**

If you switch from Edit or Object Mode into Texture Paint Mode, you’ll see that our model is completely pink. That’s because we first need an image to paint on! When there is a texture missing, Blender displays a bright pink texture instead, so it is very noticeable. Add a texture by creating a diffuse color texture slot. *Diffuse* means the base color of our object.
In the popup window that appears, you can rename the texture, set its resolution, and give it a starting color.

In order to see the new texture on the model, set the 3D viewport shading to Textured. The lack of shading in Texture Paint mode helps us to see our textures more accurately, but it does make it hard to see the model clearly. That’s why I usually enable Ambient Occlusion in the 3D view properties toolbar (N).
Now when we paint, we can see the resulting texture in the UV/Image Editor to the left.

If you’d rather paint on the 2D texture instead of the 3D object, you can do so by changing the UV/Image Editor to Paint Mode and opening the toolbar (T) to show the painting tools.
Ready for a challenge? Try to turn Suzanne the monkey into a creepy mime!

Once you’ve spent the time making a cool texture, be sure to save it! You can save it in the UV/Image Editor header under Image -> Save As Image. To include it within the .blend file itself, choose Image -> Pack Image or Pack As PNG.
Blender’s painting tools are very powerful and incredibly fun to use! To learn more about painting textures in Blender, watch this awesome YouTube tutorial by expert community member XRG.

Shading

So now we have our model, and we have our texture. The next step is shading, which is the process of giving our object a material so that it reacts to light realistically inside of our rendering engine. A rendering engine is what we use to convert our 3D scene into a final 2D image or animation. There are many renderers that work with Blender, but the two included with Blender are Blender Internal and Cycles. Blender Internal is a bit older, but still very useful for fast renders that do not need to be as realistic. Cycles is the new renderer which is a little slower, but can give much more accurate results. Cycles is still young and in development, which means that new optimizations and features are frequently being added. For this demonstration I will be working with Cycles. Blender is still set to use Blender Render by default, but you can switch to the Cycles rendering engine from the Info header at the top.

Once you make the switch to Cycles, the model may turn pink again in Texture Paint Mode. Don’t worry, your texture is still there. We just need to re-assign it a little later on.

When working with Cycles, you’ll need to use the Node Editor. You can see my layout in the image below. I first split my 3D view in half vertically, and changed the bottom half to the node editor (yellow box). Then I split my 3D view again horizontally so that one window can be set to Rendered shading (red box). I also switched my properties window over to the Materials tab (blue).
When you click the Use Nodes button, you’ll notice two nodes appear in the Node Editor. Cycles has about 75 different nodes, and each one accomplishes a very specific task. To create materials, we use nodes to tell Blender exactly how we want our material to look. Nodes can be pretty overwhelming at first, so we’ll just start with the basics.

You can think of a *node* as one step in a flowchart, or a line of code in a program. If we wanted to visualize a simple math problem in node form, it might look like this:

```
<table>
<thead>
<tr>
<th>Input</th>
<th>Operation</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>12</td>
<td>x2</td>
<td>=24</td>
</tr>
</tbody>
</table>
```

Each node is one step of the equation. The sockets on the left are input sockets that receive information, and the sockets on the left output information.

You can click on an output socket and drag it to an input socket to connect two nodes together.

In the node editor, the node to the very right is labeled “Material Output” because it is the final output for our material. Anything not connected to this will not affect our material. The node to the left is labeled “Diffuse Shader”. A *shader* defines how light will react to our object.
Explaining exactly how Cycles works would take quite a few pages, so it’s best if you can just see it in action. Before continuing on to the next step, I highly recommend you watch the following video tutorials so that you can quickly get an understanding of how it all works:

1. Intro to Cycles
2. Texturing in Cycles
3. Another Intro to Cycles

Ready to make a new material? For this example, I’m going to make our creepy monkey from earlier look like a plastic toy.

Before we can even see the material though, we should set up a simple scene so that we can actually see what’s going on. In the image below, you can see that I’ve added a plane and rotated the monkey head to sit on top. Then, I added a lamp (Add -> Lamp -> Point) and turned the strength up to 500.
Ok, now back to that monkey. When you have it selected, play around with the diffuse shader’s color input. If you turn it to red, the monkey will turn red accordingly. The *diffuse* shader is like the material’s base color. It does not reflect the light directly, but rather scatters or *diffuses* the rays that hit it. To apply the texture we painted earlier, add a texture node with Add -> Texture -> Image Texture.

You’ll notice that the model turned pink again, and that’s because we haven’t assigned a texture, just like before. You can either open a new image from your computer with the Open button, or choose an existing texture with the picture icon directly to the left of that.
Now we can see my horrendous paint job in all its glory. But it doesn’t look like a plastic toy yet, because it doesn’t have any reflections!

For reflections, we need a *glossy* shader. You can add one with Add -> Shader -> Glossy. While you’re at it, go ahead and add a *mix* shader as well so that we can combine the diffuse and glossy shaders together. Plug the diffuse and glossy into the mix shader, and connect the mix shader to the Material Output to get the following result:
The mix factor (Fac) is set to 0.5, which means that now our material is 50% diffuse and 50% glossy.

In order to see our material better, I'm going to set the monkey's shading to smooth and give it a subdivision surface modifier. Remember that flat or smooth shading can be set in the toolbar.

If you would like your monkey to be more reflective, decrease the glossy shader's roughness factor. A value of 0 is perfectly reflective while a value of 1 is very diffused.

Here's where things get cool. We can plug nodes into the Mix Shader's Fac value to control where each shader appears on the model. I only want the glossy shader to appear around the edges, so I will add a Layer Weight node and connect the Fresnel (wondering what the Fresnel Effect is?) output to the Mix's factor.
Now it actually looks like real plastic!

That’s it for this section, but there is SO MUCH to cover when it comes to shading and Cycles. To get you started, I’ve put together a list of some of the best resources to help you along the way:

1. Realistic Cycles Materials
2. Shading the Pancake Hobo
3. Cycles Shader Encyclopedia
4. Cycles Render Settings Explained
5. Realistic Texturing
6. Cycles Encyclopedia (ebook)
7. Shader Forge
Animation

Creating 3D objects is fun, but it’s even more awesome to see them move. Animation is what makes our creations look alive!

Keyframes

If you’re familiar with traditional hand-drawn animation, you may already know that animators do not draw every frame in order. They first draw all of the important or “key” frames first, before filling the in-betweens.

In 3D animation, we only need to set the important frames (called keyframes), and the software will automatically calculate the in-betweens. What a time saver!

There are four different ways to set keyframes in Blender, and I’ll show to how to use each one to animate the default cube.

The first way is to use the hotkey “I” (for Insert keyframe). This will bring up a list of attributes that can be keyframed.
Inserting a location keyframe will only store location data, a rotation keyframe will only store rotation data, a scaling keyframe will only store the object’s scale, and so on. You can store all three with the LocRotScale keyframe.

It’s best to only store the transformations that you need, but more on that later. For now let’s just insert a location keyframe. Now move to frame 100, by scrubbing along the timeline or by typing 100 into the frame counter that’s just left of the playback buttons. You can see that our keyframe is represented by a yellow tick mark on frame 1.

Now that we’ve told Blender where the cube should be on frame 1, let’s move the cube to the right on frame 100 and insert another location keyframe. If you play using the play button or scrub through the timeline, our cube is now moving!

The single arrow play button will play through the animation at normal speed, the double arrows will jump between keyframes, and the double arrows hitting the wall will jump to the end or beginning.

We have the cube moving, but let’s add some rotation as well. We’ll do this by using the keying sets. You can specify which type of data you would like stored in the keying set dropdown (dropup?). Choose rotation. Now if you press the key button directly to the right (or press the hotkey “I”), Blender will add a
rotation keyframe. To remove a keyframe, use the slashed-key button to the right or the hotkey "ALT+I".

On frame 100, rotate the cube a bit and press "I" again. Since they keying set is set to rotation only, Blender knows to only insert a rotation keyframe.

The third way to set a keyframe is again using the "I" hotkey, but on buttons instead of the 3D view. Almost any setting in Blender can be animated! If you open the properties toolbar (hotkey "N"), you’ll notice that the location and rotation transform properties have turned green. This signifies that they are animated. If they are a bright yellow-green, then they have a keyframe on the current key.

Let’s animate the cube’s scale with the scale properties. Notice how all three rotation axes (X,Y, and Z) are animated, even though I only needed it to be rotated on the X. I’ll go back to frame 1. If I press “I” over the scale properties, it will insert a keyframe for the X, Y, and Z direction. Since I only want to scale the cube in the Z direction, I’ll right click on the Z scale and press “Insert Single Keyframes”.

Now increase the Z value to 5 (notice how the transform properties are local) on frame 100 and insert another single keyframe. The below images show the change between frame 1 and 100.
The last way to insert keyframes is with automatic keying. I don’t recommend using this all the time because it’s easy to accidentally override what you already have, but it can be helpful to quickly block out poses. It will automatically insert any change you make. You can activate auto-keying by toggling the red record button to the left of the keying sets. The second key toggle that appears when auto-keying is turned on will allow you to only auto-key changes that are part of your active keying set (like rotation, scale, etc...).

With auto-keying on, go to frame 50 and drag the cube upwards. Blender will automatically add a location keyframe for you! Just remember to turn auto-keying off when you’re finished so you don’t accidentally overwrite your animation.

There’s a whole world of fun things to do with animation! Here’s a great couple Blender courses to help you get started right away:

1. [Animation Fundamentals](#)
2. [Character Animation Toolkit](#)

### Physics

If keyframe animation isn’t your thing, perhaps physics simulations are! It’s a lot of fun to smash, explode, and dissolve things, but it’s a little bit more advanced. These tutorials will guide you through the basics:

#### Particles
1. [Logo Dissolve](#)
2. [Fluid Particles](#)
3. [Chain Mail](#)
4. [Detailing Destruction](#)
5. [Boids Particles](#)
6. [Serious Particle Animation Training](#)

#### Rigid Bodies
1. [Quick Intro](#)
2. [Falling Buttons](#)
3. [Chain Physics](#)
4. [Fracturing Objects](#)
5. [Shattering Glass](#)

#### Cloth
1. [Cloth for Arch-Viz](#)
2. [Modelling with Cloth](#)
Fire and smoke
1. Intro to Fire
2. Working with Obstacles
3. Explosions
4. Inkdrop Effect
5. Rocket with Smoke Trail
6. Car Drift
7. Tornado

Fluids
1. Fluid Sim Introduction
2. Coffee Cup Shatter
3. Oceans with Foam
Rendering and Compositing

Rendering

Before you can show off your cool 3D scenes or use them in Photoshop or After Effects, you'll need to render them out. We've already covered how you can interactively preview your render with viewport rendered shading, so now it's time to export your still or animation as an image or movie.

Cameras

Unlike some other 3D programs, Blender always renders through the active camera object. If you have multiple cameras, the active camera is the one whose triangle is filled in. The triangle also serves to signify which direction the camera is facing.

You can also set the active camera from the Scene tab in the Properties window:
To view through the active camera, use the 3D header menu View -> Cameras -> Active Camera (Hotkey Numpad0). You can also set the active object as the active camera with the CTRL+Numpad0, or focus the camera from your view with CTRL+ALT+Numpad0.

The Camera tab of the Properties window is where you can set your camera’s settings, such as focal length, clipping, depth of field, and so on. If you would like to emulate a specific camera (such as a Red Epic), Blender has a number of presets available.

![Camera Settings](image)

**Render Settings**

Blender’s render buttons can be found at the very top of the Render tab in the Properties window. You can choose between Image (hotkey F12), Animation (CTRL+F12), or Audio.

In the Dimensions panel directly below, you can set the render’s resolution, frame rate, and aspect ratio.

The Output panel, right below Dimensions, is where you can specify an output path and file type. The Output panel only applies to rendering animations and not images. When rendering an animation, be sure to either set your file format to a movie type (H.264, MPEG, etc…) to render as a movie, or as an image type (PNG, JPEG, OpenEXR, etc…) to render as an image sequence. If you choose a movie format, an additional Encoding panel appears below in which you can set the codecs for video and audio. If you have no audio codec selected, no audio will be outputted.
Watch this tutorial for more information on file types.

Below these panels are render settings panels that relate to whichever render engine you are using (most likely Blender Render or Cycles). For an explanation of Cycles render settings, watch this free tutorial.

Once you hit Render, the 3D View will switch to the UV/Image Editor and the Image will render out. You can save your render with Image -&gt; Save As Image (hotkey F3).
Compositing

Many times, you’ll want to tweak your image or animation after it is finished rendering. This is called *post-processing* or *compositing*, and can be done within Blender as well. The following videos will walk you through Blender’s powerful compositor, so that you can start creating high quality effects in no time.

1. Intro to Compositing
2. Intro to Color Correction
3. Intro to Node Groups
4. Compositing Cycles Passes
5. Compositing and Tracking a Hidden Safe
Additional Resources

Well guys, it’s been fun. We’ve gone through a lot and yet we’ve barely scratched the surface. 3D can be confusing at first, but don’t be discouraged! Making great art takes practice and hard work, just like anything else. I’ve linked to a lot of tutorials already, but there is a massive amount of resources out there that I want to share with you. I’ve gathered up the best sites that I use all the time, and I hope they help you too!

Tutorials
- Blenderhd.com
- Cgcookie.com
- Cmivfx.com
- Blendedguru.com
- Blenderdiplom.com
- Creativeshrimp.com
- Cloud.blender.org
- Digitaltutors.com
- Training.cgsociety.org

News and Forums
- Blenderartists.org
- Blender.today
- Cgsociety.org
- Blender.stackexchange.com
- Blendednation.com

Assets
- Cgcookiemarkets.com
- Textures
  - Cgtextures.com
  - Plaintextures.com
  - Pixabay.com
  - Unsplash.com
- The-blueprints.com

Inspiration
- Artstation.com
- Cgsociety.org
- Behance.net
- Pinterest.com